In order to play Golf Clash your web browser and graphics card will need to support WebGL. Here is a list of of supported web browsers:
  • Google Chrome v9 or later
  • Mozilla Firefox v4.0 or later
  • Safari 6.0 or later. Please note Safari uses a setting to control WebGL support. This can be found in Preferences > Security > Allow WebGL. Please enable this.
  • Internet Explorer 11 or later
  • Microsoft Edge v0.95 or later
Golf Clash also requires that your graphics card supports DirectX 9.0 or later. To check this please type Dxdiag in your windows search and check the DirectX version used.

If you're using a browser listed above and are still having issues please contact our support team and they will be able to assist you further.